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How to Get the Starting PDF?
You can take any existing PDF document and apply Oracle BI Publisher markup. But, how do you get the initial source?
· Design the layout of your template using any application that generates documents convertible to PDF.
· Print the document using the Adobe Acrobat Distiller.
· Scan a paper document to PDF.
· Download a PDF document from a third-party Web site.
Key Issues
· When converted to PDF, your layout is treated like a set background.
· You draw your fields on top of this background when you add the markup.
· To edit the layout, you must edit your original document, and then convert back to PDF.
· The PDF template is not recommended for documents that will require frequent updates to the layout.
· The PDF template is appropriate for forms with fixed layouts, such as invoices and purchase orders.
Supported Modes
· Oracle BI Publisher supports Adobe Acrobat 5.0 (PDF Specification 1.4).
· If you are using Adobe Acrobat 6.0 (or later), use the Reduce File Size Option to save the file as Adobe Acrobat 5.0 compatible.
Adding Markup
After you have converted your document to PDF, the following procedure has to be followed:
· Adobe Acrobat 5.0 users:
1. Select Form Tool from the toolbar.
2. Draw a form field box in the position on the template where you want the field to display.
3. In the Name field of the Field Properties dialog box, enter the placeholder name which must match the XML source field name.
4. Select Text from the Type drop-down list.
5. You can use the Field Properties dialog box to set other attributes such as enforce maximum character size, field data type, data type validation, visibility, and formatting.
Adding Markup
· Adobe Acrobat 6.0 (or later) users
1. Select Text Field Tool from the Forms toolbar.
2. Draw a form field box in the position on the template where you want the field to display. Drawing the field opens the Text Field Properties dialog box. 
3. On the General tab, enter a name for the placeholder in the Name field, which must match your XML source.
4. You can use the Text Field Properties dialog box to set other attributes for the placeholder. For example, enforce maximum character size, set field data type, data type validation, visibility, and formatting.
Supported Field Properties Options
· Appearance
· Border settings: Color, background, width, and style
· Text settings: Color, font, size
· Common properties (General in 6.0): Read-only, required, visible/hidden, orientation (in degrees) 
· Border style
· Options tab
· Multi-line
· Scrolling text
· Format tab: Number category options only
· Calculate tab: All calculation functions
Adding a Check Box
· Acrobat 5.0 users
1. Draw the form field.
2. In the Field Properties dialog box, enter a name for the field.
3. Select Check Box from the Type drop-down list.
4. Select the Options tab.
5. In the Export Value field, enter the value that the XML data field should match to enable the “checked” state. For example, enter “Y” for each check box field.
Adding a Check Box
· Acrobat 6.0 (or later) users
1. Select Check Box Tool from the Forms Toolbar. 
2. Draw the check box field in the desired position.
3. On the General tab of the Check Box Properties dialog box, enter a name for the field.
4. Select the Options tab.
5. In the Export Value field, enter the value that the XML data field should match to enable the “checked” state. For example, enter “Y” for each check box field.
Adding an Option Button Group
· Acrobat 5.0 users
1. Draw the form field.
2. In the Field Properties dialog box, enter a name for the field. Each option button you define to represent this value can be named differently, but must be mapped to the same XML data field.
3. Select Option Button from the Type drop-down list.
4. Select the Options tab.
5. In the Export Value field, enter the value that the XML data field should match to enable the “on” state. For example, enter “Standard” for the field labeled Standard. Enter “Overnight” for the field labeled Overnight.
Adding an Option Button Group
· Acrobat 6.0 (or later) users
1. Draw the form field.
2. In the Field Properties dialog box, enter a name for the field. Each option button you define to represent this value can be named differently, but must be mapped to the same XML data field.
3. Select Option Button from the Type drop-down list.
4. Select the Options tab.
5. In the Export Value field, enter the value that the XML data field should match to enable the “on” state. For example, enter “Standard” for the field labeled Standard. Enter “Overnight” for the field labeled Overnight.
Defining Groups of Repeating Fields
To define the area to contain the group of repeating fields:
1. Insert a form field at the beginning of the area that is to contain the group. (Acrobat 6.0 users should select Text Field Tool, then draw the form field.)
2. In the Name field of the Field Properties window, enter any unique name you choose. This field is not mapped.
3. Acrobat 5.0 users: Select Text from the Type 
drop-down list.
4. In the Short Description field (Acrobat 5.0) or the Tooltip field (Acrobat 6.0) of the Field Properties window, enter the following syntax: <?rep_field="BODY_START"?>
5. Define the end of the group area by inserting a form field at the end of the area that is to contain the group.
6. In the Name field of the Field Properties window, enter any unique name you choose. This field is not mapped. Note that the name you assign to this field must be different from the name you assigned to the <?rep_field="BODY_START"?> field. 
7. Acrobat 5.0 users: Select Text from the Type 
drop-down list.
8. In the Short Description field (Acrobat 5.0) or the Tooltip field (Acrobat 6.0) of the Field Properties window, enter the following syntax: <?rep_field="BODY_END"?>
Defining Groups of Repeating Fields
To define a group of repeating fields:
1. Insert a placeholder for the first element of the group.
2. For each element in the group, enter the following syntax in the Short Description field (Acrobat 5.0) or the Tooltip field (Acrobat 6.0): <?rep_field="T1_Gn"?>               where n is the row number of the item in the template.
Note: The placement of this field in relationship to the BODY_START tag defines the distance between the repeating rows for each occurrence.

Defining Groups of Repeating Fields
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Defining Groups of Repeating Fields
For example, the group in the sample report is laid out in three rows:

· For the fields belonging to the row that begins with POL_ITEM_DESCRIPTION, enter <?rep_field="T1_G1"?>.

· For the fields belonging to the row that begins with C_FLEX_ITEM_DISP, enter <?rep_field="T1_G2"?>.

· For the fields belonging to the row that begins with C_SHIP_TO_ADDRESS, enter <?rep_field="T1_G3"?>.

Adding Page Numbers
To add page numbers, define a field in the template where you want the page number to appear and enter an initial value in that field as follows:
1. Decide the position on the template where you want the page number to be displayed.
2. Create a placeholder field called @pagenum@.
Enter a starting value for the page number in the Default field. If the XML data includes a value for this field, the start value assigned in the template will be overridden. If no start value is assigned, it will default to 1
Adding Page Breaks
· You can define a page break in your template to occur after a repeatable field. 
· To insert a page break after the occurrence of a specific field, add the following to the syntax in the Short Description field of the Field Properties dialog box (use the Tooltip field for Acrobat 6.0): page_break="yes"
· For example:

<?rep_field="T1_G3", page_break="yes"?>

Note that in order for the break to occur, the field must be populated with data from the XML source. 
Performing Calculations
Adobe Acrobat provides a calculation function in the Field Properties dialog box. To create a field to display a calculated total on your report:
1. Create a text field to display the calculated total. Give the field any name you choose.
2. In the Field Properties dialog box, click the Format tab.
3. Select Number from the Category list.
4. Click the Calculate tab.
5. Select the Option Button next to “Value is the operation of the following fields:” 
6. Select Sum from the drop-down list.
7. Select the Pick Button and select the fields that you want totaled.
Run-Time Behavior
Placement of repeating fields: As already noted, the placement, spacing, and alignment of fields that you create in the template are independent of the underlying form layout. At run time, Oracle BI Publisher places each repeating row of data according to calculations performed on the placement of the rows of fields that you created, as follows:
First occurrence:
· The first row of repeating fields will be displayed exactly where you have placed them in the template.
Run-Time Behavior
Second occurrence, single row:
· To place the second occurrence of the group, Oracle BI Publisher calculates the distance between the BODY_START tag and the first field of the first occurrence. The first field of the second occurrence of the group will be placed this calculated distance below the first occurrence.
Second occurrence, multiple rows:
· If the first group contains multiple rows, the second occurrence of the group will be placed the calculated distance below the last row of the first occurrence. 
· The distance between the rows within the group will be maintained as defined in the first occurrence. 
Downloaded PDFs
There are many PDF forms available online that you may want to use as templates for your report data. For example, government forms that your company is required to submit. You can use these downloaded PDF files as your report templates, supplying the XML data at run time to fill the report out. 
Some of these forms already have form fields defined; some do not. If the form fields are not already defined in the downloaded PDF, you must create them.
Using Downloaded PDFs with Form Fields
1. Download the PDF file to your local system.
2. Open the file in Adobe Acrobat.
3. Select Text Field Tool (Acrobat 6.0 users) or the Form Tool (Acrobat 5.0 users). This will highlight text fields that have already been defined.
4. To map the existing form fields to the data from your incoming XML file, you must rename the fields to match the element names in your XML file.
5. Open the text form field Properties dialog by either double-clicking the field or by selecting the field, and then selecting Properties from the shortcut menu.
6. In the Name field, enter the element name from your input XML source.
7. Repeat for all fields that you want populated by your data file.
eText Templates
· An eText template is an RTF-based template that is used to generate text output for Electronic Funds Transfer (EFT) and Electronic Data Interchange (EDI). 
· An eText template is applied at run time by Oracle BI Publisher to an input XML data file to create an output text file that can be transmitted to a bank or other customer. Because the output is intended for electronic communication, the eText templates must follow very specific format instructions for exact placement of data.
eText Templates
Note: An EFT is an electronic transmission of financial data and payments to banks in a specific fixed-position format flat file (text).

EDI is similar to EFT, except it is not only limited to the transmission of payment information to banks. It is often used as a method of exchanging business documents, such as purchase orders and invoices, between companies. EDI data is delimiter-based and also transmitted as a flat file (text).

Files in these formats are transmitted as flat files, rather than printed on paper. The length of a record is often several hundred characters and therefore, difficult to lay out on standard size paper.

To accommodate the record length, the EFT and EDI templates are designed using tables. Each record is represented by a table. Each row in a table corresponds to a field in a record. The columns of the table specify the position, length, and value of the field.

These formats can also require special handling of the data from the input XML file. This special handling can be on a global level (for example, character replacement and sequencing) or on a record level (for example, sorting). Commands to perform these functions are declared in command rows. Global-level commands are declared in setup tables.

At run time, Oracle BI Publisher constructs the output file according to the setup commands and layout specifications in the tables.

Structure of eText Templates
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Row Types
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Row Types
Command rows are used to specify commands in the template. Command rows always have two columns—command name and command parameter. Command rows do not have column headings. The commands control the overall setup and record structures of the template.

Blank rows can be inserted anywhere in a table to improve readability. Most often they are used in the setup table, between commands. Blank rows are ignored by Oracle BI Publisher when the template is parsed.

Data column headers specify the column headings for the data fields (such as Position, Length, Format, Padding, and Comments). A column header row usually follows the LEVEL command in a table (or the sorting command, if one is used). The column header row must come before any data rows in the table. Additional empty column header rows can be inserted at any position in a table to improve readability. The empty rows will be ignored at run time.

Data rows contain the data fields to correspond to the column header rows.

Constructing Data Tables
· Data tables contain a combination of command rows and data field rows. 
· Each data table must begin with a LEVEL command row that specifies its XML element. Each record must begin with a NEW RECORD command that specifies the start of a new record, and the end of a previous record (if any).
The required columns for the data fields vary depending on the template type
Command Rows
Command rows always have two columns, command name and command parameter. The supported commands are:
· LEVEL
· NEW RECORD
· SORT ASCENDING
· SORT DESCENDING
· DISPLAY CONDITION
Command Rows
Level Command
The level command associates a table with an XML element. The parameter for the level command is an XML element. The level will be printed once for each instance the XML element appears in the data input file.

The level commands define the hierarchy of the template. For example, Payment XML data extracts are hierarchical. A batch can have multiple child payments, and a payment can have multiple child invoices. This hierarchy is represented in XML as nested child elements within a parent element. By associating the tables with XML elements through the level command, the tables will also have the same hierarchical structure.

Similar to the closing tag of an XML element, the level command has a companion end-level command. The child tables must be defined between the level and end-level commands of the table defined for the parent element.

An XML element can be associated with only one level. All the records belonging to a level must reside in the table of that level or within a nested table belonging to that level. The end-level command will be specified at the end of the final table.

New Record Command
The new record command signifies the start of a record and the end of the previous one, if any. Every record in a template must start with the new record command. The record continues until the next new record command, or until the end of the table or the end of the level command.

A record is a construct for the organization of the elements belonging to a level. The record name is not associated with the XML input file.

A table can contain multiple records, and therefore multiple new record commands. All the records in a table are at the same hierarchy level. They will be printed in the order in which they are specified in the table.

Sort Ascending and Sort Descending Commands
Use the sort ascending and sort descending commands to sort the instances of a level. Enter the elements you want to sort by in a comma-separated list. This is an optional command. When used, it must come right after the (first) level command and it applies to all records of the level, even if the records are specified in multiple tables.

Display Condition Command
The display condition command specifies when the enclosed record or data field group should be displayed. The command parameter is a Boolean expression. When it evaluates to true, the record or data field group is displayed. Otherwise the record or data field group is skipped.

The display condition command can be used with either a record or a group of data fields. When used with a record, the display condition command must follow the new record command. When used with a group of data fields, the display condition command must follow a data field row. In this case, the display condition will apply to the rest of the fields through the end of the record.

Consecutive display condition commands are merged as AND conditions. The merged display conditions apply to the same enclosed record or data field group.

Structure of the Data Rows
The output record data fields are represented in the template by table rows. In FIXED_POSITION_BASED templates, each row has the following attributes (or
columns):
· Position
· Length
· Format
· Pad
· Data
· Comments
Structure of the Data Rows
The first three columns (listed in the slide) are required and must be declared in the order stated.

The Comments column is optional and ignored by the system. You can insert additional information columns if you want; however, all columns after the required ones are ignored.

Structure of the Data Rows
The output record data fields are represented in the template by table rows. In DELIMITER_BASED templates, each row has the following attributes (or
columns):
· Maximum length
· Format
· Pad
· Tag
· Comments
Setup Command Tables
A template always begins with a table that defines global attributes and program elements. The setup commands are:
· Template type
· Output character set
· New record character
· Invalid characters
· Replace characters
· Define level
· Define sequence
· Define concatenation
Summarizing eText Templates
eText templates are very specific to the application (EDI or EFT), and are rigidly and tightly controlled. Because of this, eText template creation is not trivial. The Oracle BI Publisher User’s Guide should be consulted.
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